You are not logged in.

1

Sunday, October 20th 2019, 8:26pm

Zeitverzögert Untertitel

Hallo Zusammen

Ich bin echt verzweifelt, ich habe eine US-Serie gekauft und möchte die deutschen Untertitel hinzufügen (Die Dateien habe ich alle lokal gespeichert). Habe das auch soweit geschafft, aber irgendwie im Verlauf der Serie wird es immer mehr zeitlich versetzt, dass heisst der Untertitel kommt früher, wie eigentlich gesprochen wird, am Anfang ist es noch ok, aber man merkt in der Folge immer mehr, das es immer schlimmer wird. Am Ende der jeweilige Folge ist es dann 10 Sekunden verschoben und in der Mitte der Serie sind es 5 Sekunden. Es wird also pro Minute der jeweilige Folge immer schlimmer.

Ich habe zwar gefunden, wie man die Zeiten verschieben kann. Verschiebe ich den Timer um 10 Sekunden mit dem Subtile Workshop stimmt es zwar dann am Schluss, aber dafür am Anfang kommen die deutschen Untertitel viel zu spät.

Hat jemand eine Idee, wie man sowas fixen kann? Es betrifft alle Folgen und das Dateiformat ist MP4.

Derwisch

~ Stammesälteste ~

Posts: 3,184

Location: Wien

  • Send private message

2

Sunday, October 20th 2019, 10:14pm

Klingt, als würden deine Videos nicht zu den Subs passen.

Lies mal hier: Die Untertitel sind asynchron - was kann ich tun?

3

Monday, October 21st 2019, 6:20am

Es geht um die Serie Arrow Staffel 7 und habe diese im iTunes Store gekauft. Denke eher da kann man irgendwo was einstellen, weil ich bin sicher nicht der einzigste der die Serie im Store gekauft hat und deutsche Untertitel hinzufügen möchte. Wenn es irgendwo aufgenommen wurde, und Werbung ab und zu kommen würde, leuchtet das bestimmt ein.
Evtl sonst noch eine Idee?

Hampton

ProbieMentor

Posts: 5,887

Location: Berlin

Occupation: Selbständig

  • Send private message

4

Monday, October 21st 2019, 10:08am

Ich denke, du hast folgendes Problem. Schau mal hier: Video von 23,976 zu 25fps - oder audio von 25fps zu 23,976?
"...die deutsche Tonspur ja auf das 25fps Video "gesampled"... Die englische Version ist in 23,976 FPS," du musst also die Subs als die Version anpassen.

5

Monday, October 21st 2019, 11:27am

Vielen Dank für deinen guten Hinweis. Ja das klingt für mich irgendwie logisch mi , dass irgendwas mit den FPS zu tun haben könnte. Am Schluss kommt die Übersetzung im Subtitle viel früher, als es effektiv gesprochen wurde. Ich kenne mich leider noch viel zu wenig aus, daher stelle ich so komische «einfache» Fragen.

Was müsste ich bei diesem Programm «Subtitle Workshop» korrekt einstellen, damit es dann korrekt läuft? Wenn ich den Subtitle im Subtitle Workshop öffne, da sehe ich den Einstellungen Input FPS 25 und FPS auch 25, was müsste ich dort korrekt einstellen (Attachment zeigt 30, aber effektiv wäre es 25 wenn ich den Subtitle öffne). Mit dem Subtitle Workshop kann ich ja nur die Subtitle «SRT» bearbeiten, daher ist das bestimmt einfacher wie die MP4 Datei zu bearbeiten. Muss ich dann auch den gesammten Texte markieren, wenn ich es bearbeiten will, oder übernimmt es die FPS Einstellungen automatisch auf die ganze SRT Datei?
Yojilein has attached the following image:
  • FPS Workshop.JPG

Hampton

ProbieMentor

Posts: 5,887

Location: Berlin

Occupation: Selbständig

  • Send private message

6

Monday, October 21st 2019, 12:02pm

Ich habe es noch nie gemacht, aber du muss ja die Untertitel auf die gleiche Framerate wie das Video bringen. Daher würde ich das Video im STW laden, dann müsste bei "Input FPS" die verwendete Framerade angezeigt werden. Bei "FPS" (also die FPS für die Untertitel) dann die gleiche Framerate eintragen und auf "Speicher" klicken. Dann dürfte der Subs auf die neue Framerate angepasst worden sein.

7

Monday, October 21st 2019, 12:20pm

Mit STW meinst du vermutlich Subtitle Workshop.

Das hab ich auch bereits mal probiert, aber es zeigt an, dass meine MP4 keine gültige Videodatei an. Vermutlich erkennt es das STW irgendwie nicht. Vermutlich funktioniert das nur mit AVI anstelle von MP4. Hast du sonst eine Idee, wie ich die beiden korrekte Framerate des Videos sonst noch herausfinden könnte?

Hampton

ProbieMentor

Posts: 5,887

Location: Berlin

Occupation: Selbständig

  • Send private message

8

Monday, October 21st 2019, 12:33pm

Ich würde einfach den Sub im STW laden, und dann "FPS" auf 23,976 stellen, dann ändern sich die Zeiten. Abspeichen und schauen, ob es passt.

9

Monday, October 21st 2019, 1:02pm

Alles klar, ich markiere dann mal den gesammte Texte und versuche das mal so umzustellen.

Muss ich hier nur den Input FPS auf 23,976 umstellen oder auch der normale FPS auf 23,976 (siehe Foto), oder muss nur der einte Teil von beiden auf 23,976 umgestellt werden?
Yojilein has attached the following image:
  • FPS Workshop.JPG

10

Monday, October 21st 2019, 1:35pm

Habe gerade noch etwas sehr spannendes zu diesem Thema gefunden:

Immer größere Verzögerung der Untertitel im VLC

Ich habe die deutschen Untertitel für 720p.HDTV heruntergeladen, aber auf dem obenstehenden Link gelesen, dass man bei Filme, die man im Internet (iTunes, netflix und amazon etc.), herunterlädt, die Art «Web-DL» als Untertitel herunterladen muss. Evtl. löst das hier die Probleme.

Das werde ich heute bestimmt auch noch versuchen.

11

Monday, October 21st 2019, 3:48pm

Du musst erst einmal schauen, welche Bitrate dein Video hat, Rechtsklick auf das Video > Details.
Wenn dein Video 25 Bilder pro Sekunde hat und der Sub 23, dann hilft auch der WEB-DL-Sub nicht.

12

Monday, October 21st 2019, 4:09pm

Hallo Alex

Ok danke für deine Info, ich werde in den Eigenschaften der MP4 Datei schauen, ob ich was finde. Ansonsten im VLC Player kann man die Bildwiederholrate herausfinden und dann schauen wir weiter. Evtl. finde ich es dann heraus und sonst schreibe ich hier nochmals rein. Wenn es geklappt hat, schreibe ich es natürlich auch rein, dann haben andere Benutzer auch gleich einen Hinweis.

13

Monday, October 21st 2019, 4:28pm

Ja, Feedback ist immer gut :thumbup:

14

Monday, October 21st 2019, 6:30pm

Also ich habe es probiert mit dem Subtitle Workshop zu bearbeiten, dass hat irgendwie nicht geklappt. Es kamen keine Änderungen, obwohl ich es gespeichert habe.

Habe daher die richtige Untertiteldateien heruntergeladen «Web-DL» und siehe, jetzt stimmt alles.

Vielen Dank an alle für die guten Tipps.

15

Monday, October 21st 2019, 8:32pm

Freut mich und danke fürs Feedback!

16

Monday, October 21st 2019, 11:48pm

Ich muss mich leider korrigieren, von der Folge 01 bis und mit Folge 09 und dann von Folge 17 bis Folge 22 war alles super. Ab Folge 10 (S07E10) bis und mit Folge 16 stimmt es ganz und gar nicht mehr. Ab Folge 17 bis Folge 22 ist dann plötzlich alles wieder bestens.

Bei der Version 720p.HDTV natürlich das bekannte Problem (wie am Anfang geschrieben) und dann habe ich die Web-DL genommen (wie bei den ersten 9 Folgen und von der Folge 16 bis Folge 22 der 7. Staffel). Zwischen der Folge 10 bis und mit Folge 16 fing es schon ganz falsch an, es kam am Anfang schon keine Untertitel. Nach 00:53 Sekunden kommen dann welche, aber wie erwähnt, es ist komplett falsch, schlimmer wie das 720p.HDTV. Habe die Arrow Season 7 in iTunes gekauft und seit der Folge 10 bis Folge 16 stimmt gar nichts mehr.

Ist hier evtl. an den Subtiles was falsch? Kann mir nicht vorstellen, dass bei iTunes irgendwie was falsch ist und ich habe eine andere Version noch heruntergeladen und da war das gleiche Problem. Hat jemand noch eine Idee?

Hoffe konnte mich irgendwie so gut wie es geht ausdrücken und man versteht es.

17

Tuesday, October 22nd 2019, 7:48am

Habe jetzt die fehlenden Subtitel mit dem Tool «Subtitle Workshop» bearbeitet, jede Folge von 10 - Folge 16 hat mit der Version von iTunes nicht gepasst, Die einten waren sogar über 50 Sekunden falsch erstellt, entweder kommen die Untertitel zu früh oder zu spät. Ich frage mich, ob iTunes andere Versionen hat wie Amazon oder sonst wo, wo man die Daten im Internet kaufen / herunterladen kann.

Jetzt passt es soweit und es stimmen nun nach langem hin und her alle iTunes MP4 Dateien mit den WEB-DL Subitles.

18

Tuesday, October 22nd 2019, 11:41am

Also, unsere Untertitel werden für bestimmte Releases/Videos erstellt.
Du kannst dir gar nicht vorstellen, wie unterschiedlich manche Releases sind, obwohl sie alle WEBRip oder WEB-DL sind.
Deswegen wundert mich eher, dass es bei manchen auf Anhieb gepasst hat.

Gesendet von meinem SM-G970F mit Tapatalk

19

Tuesday, October 22nd 2019, 12:00pm

Ok das wusste ich nicht, ist ja auch Neuland für mich, aber soweit passt das ja, und wenn man weiss, wie man es bearbeiten muss, dann kommt man auch schon weiter.